It appears that issues with Cloudflare have now been resolved. We will keep monitoring the situation for a little longer before resolving this incident. Thank you for your patience and understanding.
Posted Feb 02, 2026 - 10:01 GMT
Update
We are continuing to monitor this issue.
Posted Feb 02, 2026 - 09:27 GMT
Investigating
The Satchel One website accessibility may be affected due to an issue with one of our services, Cloudflare. Similar issues could be affecting other school services. We sincerely apologise for the inconvenience. We will be back online as soon as Cloudflare issues have been resolved. https://www.cloudflarestatus.com/